hack のためのネタ帳, etc,,,

20161229: Cygwin - Python3 - Matplotlib の続きだけど、
現在 stable な最新版である v1.11.3 だと xlocale.h が解決出来ずに失敗する。
Cygwin だと wxWidget の xlocale.h しか見当たらなかったんだけど、これはパスが届いてなくてダメ。
パスを通しても、なんかいろいろと文句を言われる。
これは、以下のフォーラムの投稿によれば、/usr/include/locale.h を xlocale.h としてシンボリックリンクしておいて、パスを通しておけばよいらしい。
  • Alpine Linux forums / 2016-07-06: xlocale.h
実際、以下のようにすれば、アドホックに問題の回避は可能だった。
mkdir /tmp/include
ln -s /usr/inclue/locale.h /tmp/include/xlocale.h
export C_INCLUDE_PATH=/usr/include:/tmp/include
pip3 install numpy
GitHub の master ではこの問題は既に 154b2c1 で対処されているけど、これはまだバージョンタグが振られておらず、master を clone して pip install . してみると cython が入ってないとビルド出来ないが、以下のようにすれば解決は出来た。
pip3 install cython
git clone https://github.com/numpy/numpy
cd numpy
pip3 install .

コメントをかく


ユーザーIDでかく場合はこちら

画像に記載されている文字を下のフォームに入力してください。

「http://」を含む投稿は禁止されています。

利用規約をご確認のうえご記入下さい

Wiki内検索

フリーエリア

編集にはIDが必要です