AUXポート経由で、外付けアナログモデムからダイヤルアップ
<ToDO>
パスワード暗号化
PAPの必要性。(=CHAPのみで良いのでは?)
自動切断の設定。
▲部分の確認

<状況>
ISPにダイヤルアップ:OK
ISPからIPアドレス取得:OK
ping飛ばして、自動ダイヤルアップ:OK


<物理構成>
壁面TELジャック

|TEL線

ADSLモデム

|TEL線

アナログモデム(I/Oデータ DFML-560)
|<Dsub25pin>
|シリアルケーブル(自作変換ケーブル)
|<AUXポート:RJ-45>
ルータ(Cisco 2620)

|LANケーブル

PC

<想定構成>
ルータ
 e0: IPアドレス:192.168.160.001
    サブネットマスク:255.255.255.000
    DHCPサーバ機能:有効
     DHCPネットワークアドレス:192.168.160.000
     DHCPサブネットマスク:255.255.255.000
     DHCP配布情報(DNSサーバアドレス情報):208.67.222.222
     DHCP配布除外アドレス:192.168.160.001
 aux0: IPアドレス:自動取得

    ネームサーバアドレス:208.67.222.222
    スタティックルーティング:0.0.0.0 0.0.0.0 to aux0
    ダイヤルアップ設定
     ダイヤル番号:00000088335010
      *ADSLモデムを通して電話線を接続しており、
       ADSLによるIP電話経由でのコールを回避するため、先頭に0000を付与している。
     PPP認証方式:PAP
      ダイヤルアップユーザ名:solo
      ダイヤルアップパスワード:solo

<設定手順>
Router>enable
Router#erase startup-config
Erasing the nvram filesystem will remove all files! Continue? [confirm] ←ENTERキー押下。

Router#reload
Proceed with reload? [confirm] ←ENTERキー押下。

Would you like to enter the initial configuration dialog? [yes/no]:no
Would you like to terminate autoinstall? [yes]: yes

Router>enable
Router#configure terminal
Router(config)#ip dhcp excluded-address 192.168.160.1
Router(config)#ip name-server 208.67.222.222
Router(config)#no ip finger
Router(config)#ip route 0.0.0.0 0.0.0.0 Async 65 permanent

Router(config)#chat-script setuzoku1111 ABORT ERROR ABORT BUSY ABORT NO "" \dATF0 OK \dATD\T TIMEOUT 60 CONNECT
Router(config)#chat-script setudan1111 \dATH0
Router(config)#modemcap entry modemcap1111:MSC=&F0 ATL3 ATM2

Router(config)#ip dhcp pool dhcp1111
Router(dhcp-config)#network 192.168.160.0 255.255.255.0
Router(dhcp-config)#default-router 192.168.160.1
Router(dhcp-config)#dns-server 208.67.222.222
Router(dhcp-config)#exit

Router(config)#interface FastEthernet 0/0
Router(config-if)#ip address 192.168.160.1 255.255.255.0
Router(config-if)#ip nat inside
Router(config-if)#no shutdown
Router(config-if)#exit

Router(config)#interface Async65
Router(config-if)#async default routing
Router(config-if)#async mode interactive
Router(config-if)#mtu 1450
Router(config-if)#bandwidth 115200
Router(config-if)#ip address negotiated
Router(config-if)#ip nat outside
Router(config-if)#encapsulation ppp
Router(config-if)#keepalive 600
Router(config-if)#dialer in-band
Router(config-if)#dialer idle-timeout 0
Router(config-if)#dialer string TOW00000088335010 modem-script modemcap1111 system-script setuzoku1111
Router(config-if)#dialer-group 1
Router(config-if)#no peer default ip address
Router(config-if)#no fair-queue
Router(config-if)#no ppp lcp fast-start
Router(config-if)#ppp authentication chap pap callin
▲Router(config-if)#ppp chap hostname solo
▲Router(config-if)#ppp chap password solo
Router(config-if)#ppp pap sent-username solo password 0 solo
Router(config-if)#exit

Router(config)#line aux 0
Router(config-line)#no exec
Router(config-line)#exec-timeout 0 0
Router(config-line)#stopbits 1
Router(config-line)#speed 115200
Router(config-line)#flowcontrol hardware
Router(config-line)#modem inout
Router(config-line)#modem autoconfigure type modemcap1111
Router(config-line)#flush-at-activation
Router(config-line)#script dialer setuzoku1111
Router(config-line)#transport input all
Router(config-line)#autoselect ppp
Router(config-line)#exit

Router(config)#dialer-list 1 protocol ip permit


確認コマンド
・ダイヤルアップ時の認証状況をリアルタイムで確認
Router#debug ppp authentication
 *Mar 1 00:36:15.387: %LINK-3-UPDOWN: Interface Async65, changed state to up
 *Mar 1 00:36:15.387: As65 PPP: Using dialer call direction
 *Mar 1 00:36:15.387: As65 PPP: Treating connection as a callout
 *Mar 1 00:36:15.387: As65 PPP: Session handle[2C000002] Session id[2]
 *Mar 1 00:36:15.387: As65 PPP: Authorization required
 *Mar 1 00:36:15.387: As65 PPP: No remote authentication for call-out
 *Mar 1 00:36:19.391: As65 PPP: No authorization without authentication
 *Mar 1 00:36:19.391: As65 PAP: Using hostname from interface PAP
 *Mar 1 00:36:19.391: As65 PAP: Using password from interface PAP
 *Mar 1 00:36:19.391: As65 PAP: O AUTH-REQ id 2 len 14 from "solo"
 *Mar 1 00:36:25.127: As65 PAP: I AUTH-ACK id 2 len 5
"赤字の箇所が、
 NAK だと、認証に失敗している。
 ACK だと、認証に成功している。"

・ダイヤルアップ接続後、接続が確立しているか確認
Router#show line 65


参考
http://wiki.livedoor.jp/hide_system/d/Cisco%a5%b3%...
http://www.cisco.com/japanese/warp/public/3/jp/ser...


AUXポート同士を接続する
http://www.cisco.com/japanese/warp/public/3/jp/ser...
http://lists.lug.ro/lurker/message/20071205.100119...


AUXポートにモデムを接続(ダイヤルイン)
http://www.cisco.com/japanese/warp/public/3/jp/ser...

コメントをかく


「http://」を含む投稿は禁止されています。

利用規約をご確認のうえご記入下さい

▼当HP内検索▼

▼メインメニュー▼



管理者用リンク
書籍(技術書)
・利用ソフト一覧
・Ethereal/Wireshark

転送速度




・powershell

・VBA










・Microsoft SQLserver








●CentOS6.9


▼動画サーバ関係

MP3について
DVDからのMP3変換について?
DVDからの動画変換について



▼自転車関係
・Panasonic CRAZY BOY

▼自動車関係
・SUZUKI エブリワゴンDA62W


▼Linux/Unix関係
・Linux基礎(パッケージ)
・Linux基礎(システム構成)
・Linux(Debian)基本コマンド
・Linuxコマンド(テキスト処理)
・Linuxコマンド(未整理)
・Linuxコマンド(ネットワーク系)
・FedoraCore OS メモ
・Debian Linux OS メモ
・Vine Linux OS メモ
・xPUD メモ

・CentOS6.4(minimal)


・solaris9 メモ
・solaris10 メモ

▼CCNA関係


▼ノートPC関連

液晶パネル

Fujitsu FMV-820MT
・Compaq Evo Notebook N110
・Panasonic Let's note CF-S51R
・Toshiba Dynabook Satellite 1800


▼デスクトップPC関連
・AOpen AX3S Pro-U
・ASUS CUSL2
・ASUS CUSL2-M


▼携帯電話
・NTT DoCoMo FOMA M1000
・FOMA P704iμ


▼モデム関連
▼ADSLモデム
・NTT ADSLモデム-NV
・NEC PA-WD605CV
・NEC PA-WD701CV
▼アナログモデム
・GVC F-1156IV/R9

▼ルータ関連
▼ルータ
・OMRON MR504DV
・FON La Fonera FON2100E
・Cisco Cisco2620
・Cisco4500M
・Cisco1601
  Cisco1603-R
  Cisco1605

・Cisco 共通メモ

・BUFFALO BLR3-TX4L
・I・O DATA NP-BBR
・NEC PA-WB7000/B (AtermWB7000H)
・マイクロ総研 NetGenesis OPT
・Persol PBR001

・YAMAHA NetVolante RTA54i
・FUJITSU NetVehicle-I

▼イーサネットコンバータ関連
・LINKSYS WET11

▼TA関連
・NEC AtermIT60D1L(S)

▼ハブ関連
・Cisco Catalyst 2924-XL-EN
・AlliedTelesis CentreCOM8216XL2
・BUFFALO LSW10/100-8
・corega FSW-5PM
・corega HUB-5PM
・CONTEC RT-1216S

▼NIC関連
・BUFFALO WLI-U2-SG54HP
・PLANEX GW-NS54GMX
・NTT-ME MN SS-LAN CARD 11 HQ

▼プリンタサーバ関連
・corega Pserver
・I・O DATA PLANT ET-FPS1E

▼デジカメ関連
・MINOLTA DiMAGE F100

▼携帯電話ケーブル関連
・BUFFALO IGM-UPDC
・OMRON ME64KTID
・OMRON ME96KTI
・SOURCENEXT SUS-USB-02 REV.1
・UP12 USB-PDC Converter
・DAISO D106

▼その他PC周辺機器
●キーボード
・Bluetoothキーボード BK3001BA
●ハンディターミナル
・ENSO BHT-6500
●ダウンスキャンコンバータ
・SC-TVEX
●CD-ROMドライブ
・NEC CD-2800D
・BUFFALO CDN-D24EX
・BUFFALO DVM-RDM16IU2
●MOドライブ
・ELECOM LMO-230-S
・FUJITSU MCF3064SS
・FUJITSU SMB-640WL2
●スピーカー
・Justy JSP-10W
●MP3プレーヤ
・SanDisk sansa e130
・NHJ V@mp VP-415
●インタフェースカード
・玄人志向 USB2.0+1394a-CB
・nbj IDE-3525
・Notebook Power Sharing
●ACアダプタ
・Universal AC Adaptor
●マウス
・Logitec Marble Mouse
・needs progres TN-30RFMOSG
●タブレット
・WACOM FAVO(ET-0405-U)
●その他
・IDEAL ME-320X(ME-320U2F)
・KY-05046S-12-H
・LifeView USB CapView
・ハードウェア(その他)
●シリアルレベルコンバータ
・シリアルレベルコンバータ


▼Windows系メモ
・DOS起動ディスク
・Microsoft OS メモ
・Microsoft 系ソフト メモ
・その他 ソフトウェアメモ
・Network Notepad
・Packet Tracerメモ
・パノラマ写真作成ソフト
・トラブル対処履歴


▼プログラミング関連
・言語比較
・VBS
・卒研事前メモ
・卒研メモ
・Windowsプログラミング
・JANコード・ISBNコード相互変換
●C言語
・文字列
・ファイル操作
●アルゴリズム
・再帰アルゴリズム
●JAVA
・Javaプログラミング
●その他
・初心者プログラミング
・ソフトウェア未整理メモ



▼家電関連
●テレビ
・SHARP AQUOS LC-20D10
・FUNAI TV-14CP
・BLUEDOT BTV-900K
・AKART AK-FTV913
・REAL LIFE JAPAN IQ-191LEDTV
AQUOS DZ3シリーズのDLNA機能
Viera V1シリーズのDLNA機能
●プロジェクタ
・crenova XPE470
●ビデオ
・FUNAI TV-14CP
●HDD&DVDレコーダ
・Toshiba RD-XS46
・NEC PK-AX10
●DVDプレーヤー
・GREEN HOUSER GH-PDV9AT
・情熱価格 DVDJ-DQ03
●メディアプレーヤー
・MINI HD MEDIA BOX 1080P
・1080P FULL HD Media Player
・1080P HD Media Player Mini 1080
・HD media player

●チューナー
・COMTEC DTW700
・HUMAX CI-S1

●アンテナ
・ADDZEST ZCP107
・マルハマ AGS-590

●ヘッドマウントディスプレイ
・VIRTUAL i/O i-glasses
●電動歯ブラシ
・ブラウン電動歯ブラシ
●電話機
・SHARP DA-C5-B
●コードレス電動ドリル、ドライバ
・BLACK&DECKER CSD300T
・RELIEF 30946?

▼カーナビ関係
Panasonic CN-GP510VD
Panasonic CN-G1100VD
▼カーステレオ関係
Kenwood U585SD

▼おもちゃ関連
●ラジコン
・ラジコンのプロポ改造


▼カー用品関連
●インダッシュTV
・ADDZEST TVS6250


▼DIY関連
・懸垂スタンド
・蓄光塗料


▼電子工作関係
・コネクタピンアサイン
・LANケーブルをAVケーブル化
・LANケーブルをRGBケーブル化
・地上デジタル放送アンテナ
・電子工作 メモ
・乾電池を充電


▼デザイン関連
●腕時計
・腕時計


▼その他

・HP製作関連メモ
・アイデアメモ

・コラム・メモ
・趣味・興味


・ToDo
・ネットインフラ?


▼資格・履歴書・マナー
・資格取得メモ
・工事担任者対策メモ
・履歴書・職務経歴書
・答辞


▼修学旅行 フランス(パリ)


▼掲示板
●掲示板
 意見・苦情・質問用に仮設置。

▼フリーエリア▼

▼おしらせ▼

管理人/副管理人のみ編集できます