■Ciscoルータ同士を、シリアルインタフェースカード同士で接続する方法
<構成>
┌―――――┐
|Cisco1601 |
└―――――┘
  |DCE
  |
  |
  | Back to Backクロスケーブル(HD60-HD60タイプ)
  |  *Ciscoからは純正品の発売はされていない。
  |
  |
  |DTE
┌―――――┐
|Cisco1601 |
└―――――┘
●step1: それぞれのルータにて、ケーブルを物理的に認識しているか確認
1.下記コマンドを実行。

Router#show controllers serial 0


2.コマンド実行結果の内容を確認する。

Router#show controllers serial 0

QUICC Serial unit 0
idb at 0x296979C, driver data structure at 0x296B3E8
SCC Registers:
General [GSMR]=0x2:0x00000000, Protocol-specific [PSMR]=0x0
Events [SCCE]=0x0000, Mask [SCCM]=0x0000, Status [SCCS]=0x0000
Transmit on Demand [TODR]=0x0, Data Sync [DSR]=0x7E7E
Interrupt Registers:
Config [CICR]=0x00368461, Pending [CIPR]=0x00000040
Mask [CIMR]=0x40000010, In-srv [CISR]=0x00000000
Command register [CR]=0x690
Port A [PADIR]=0x4030, [PAPAR]=0xEEF3
    [PAODR]=0x0010, [PADAT]=0xB1BE
Port B [PBDIR]=0x00F13E, [PBPAR]=0x0010CE
    [PBODR]=0x000000, [PBDAT]=0x0248DD
Port C [PCDIR]=0x080A, [PCPAR]=0x0200
    [PCSO]=0x0030, [PCDAT]=0x05CF, [PCINT]=0x0000
DCE V.35 serial cable attached.    ←ここに表示される。*下記の「結果パターン」表参照。

SCC GENERAL PARAMETER RAM (at 0xFF00F00)

*以下表示略


<結果パターン>
パターン表示結果
Back to BackクロスケーブルのDCE側が装着されている場合DCE V.35 serial cable attached.
Back to BackクロスケーブルのDTE側が装着されている場合DTE V.35 serial cable attached.
刺さっていない場合(=ルータがケーブルを認識していない場合No serial cable attached.

●step2: DCE側を装着したルータにて、シリアルポートの設定を実施。
Router>enable
Router#configure terminal
Router(config)#interface serial 0
Router(config-if)#ip address 192.168.0.1 255.255.255.0
Router(config-if)#clock rate 64000
Router(config-if)#no shutdown

●step3: DTE側を装着したルータにて、シリアルポートの設定と疎通確認を実施。
Router>enable
Router#configure terminal
Router(config)#interface serial 0
Router(config-if)#ip address 192.168.0.2 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#end
Router#ping 192.168.0.1


■Serial端子に外付けアナログモデムやTAを接続する。
<ToDO>
パスワード暗号化
PAPの必要性。(=CHAPのみで良いのでは?)
自動切断の設定。
▲部分の確認

<状況>
ISPにダイヤルアップ:OK
ISPからIPアドレス取得:OK
ping飛ばして、自動ダイヤルアップ:OK


<物理構成>
壁面TELジャック

|TEL線

ADSLモデム

|TEL線

アナログモデム(I/Oデータ DFML-560)

|シリアルケーブル(Cisco CAB-232MT)

ルータ(Cisco 1601)

|LANケーブル

PC

<想定構成>
ルータ
e0:IPアドレス:192.168.160.001
 サブネットマスク:255.255.255.000
 DHCPサーバ機能:有効
 DHCPネットワークアドレス:192.168.160.000
 DHCPサブネットマスク:255.255.255.000
 DHCP配布情報(DNSサーバアドレス情報):208.67.222.222
 DHCP配布除外アドレス:192.168.160.001
s0:IPアドレス:自動取得
 ネームサーバアドレス:208.67.222.222
 スタティックルーティング:0.0.0.0 0.0.0.0 to Serial0
 ダイヤルアップ設定
 ダイヤルアップ先ISP:soloot
 ダイヤル番号:00000088335010
 *ADSLモデムを通して電話線を接続しており、ADSLによるIP電話経由でのコールを回避するため、先頭に0000を付与している。
 *0088335010は、ソフトバンクテレコム系電話番号
 PPP認証方式:PAP
 ダイヤルアップユーザ名:solo
 ダイヤルアップパスワード:solo

<設定手順>
設定を初期化する。(=startup-configを削除して再起動。)
Router>enable 
Router#erase startup-config 
Erasing the nvram filesystem will remove all files! Continue? [confirm] ←ENTERキー押下。訳:nvram上のファイルシステムの消去により、全てのファイルが削除されます!続けますか?[承認]
Router#reload 
Proceed with reload? [confirm] ←ENTERキー押下。訳:再起動処理を続行しますか?[承認]
 
Would you like to enter the initial configuration dialog? [yes/no]:no訳:初期設定対話画面モードに入りたいですか?
Would you like to terminate autoinstall? [yes]: yes自動インストールモードを終了させたいですか?
 
Router>enable 
Router#configure terminal 
Router(config)#ip name-server 208.67.222.222ネームサーバのIPアドレスを登録。
Router(config)#no ip finger 
Router(config)#ip http server 
Router(config)#ip route 0.0.0.0 0.0.0.0 serial 0 permanentスタティックルートを登録。
IPアドレス0.0.0.0でサブネットマスク0.0.0.0宛のパケットは、Serial0インタフェースへ依頼する。
今回、serial0インタフェースのIPアドレスは固定でないため、”permanent”を付与している。
 
Router(config)#chat-script setuzoku1111 ABORT ERROR ABORT BUSY ABORT NO "" \dATF0 OK \dATD\T TIMEOUT 60 CONNECTダイヤルアップの接続用スクリプトを作成。
Router(config)#chat-script setudan1111 \dATH0ダイヤルアップの切断用スクリプトを作成。
Router(config)#modemcap entry modemcap1111:MSC=&F0 ATL3 ATM2アナログモデム(アイオデータDFML-560用)の初期化設定スクリプトを作成。
モデムの初期化ATコマンド(=モデムのハードウェアリセット(=AT&F0))と、AT&L3と、AT&M2 を記述した、
オリジナルの「modemcap1111」という名前のmodemcapを作成。
 ・AT&Fコマンド: 工場出荷設定を実施。(0:工場出荷設定0を指定)
 ・ATLコマンド:  内部スピーカの音量設定。(3:最大)
 ・ATMコマンド:  内部スピーカ設定。(2:常にON)
Router(config)#modemcap entry modemcap2222:MSC=Z98TA(NEC Aterm IT60用)の初期化設定スクリプトを作成。
 
Router(config)#dialer-list 1 protocol ip permitダイヤラーリストNo.001の作成。
どのパケットが来たら発呼するのかを指定する。
左記の場合、IPパケットを、Interestingパケット(=ルータがダイヤルアップする契機パケット)とする。
 
Router(config)#ip dhcp excluded-address 192.168.160.1DHCPで配布しないIPアドレスを登録。
Router(config)#ip dhcp pool dhcp1111DHCPサーバのpoolファイル(=設定ファイル)の作成。
Router(dhcp-config)#network 192.168.160.0 255.255.255.0 
Router(dhcp-config)#default-router 192.168.160.1DHCPクライアントに配布する情報(=デフォルトルート情報)を登録。
Router(dhcp-config)#dns-server 208.67.222.222DHCPクライアントに配布する情報(=DNSサーバ情報)を登録。
Router(dhcp-config)#exit 
 
Router(config)#interface ethernet 0 
Router(config-if)#ip address 192.168.160.1 255.255.255.0 
Router(config-if)#ip nat insideこのインタフェースを、NAT(PAT)において内部側(=LAN 側)として定義する。
Router(config-if)#no shutdown 
Router(config-if)#exit 
 
Router(config)#interface serial 0 
Router(config-if)#physical-layer async 
Router(config-if)#async default routing 
Router(config-if)#async mode interactiveinteractive:(=会話型)。autoselectで指定したプロトコル(PPP|SLIP)、EXECを実行できる
dedicated:(=専用)。encapsulationで指定されたプロトコルのみ使う
Router(config-if)#mtu 1450このインタフェースから送信する、パケットの最大送信サイズを1450バイトにする。
Router(config-if)#bandwidth 115200 
Router(config-if)#ip address negotiatedPPP セッション確立時に、このインタフェースにIPアドレスが動的にてアサインされるようにする。
Router(config-if)#ip nat outsideこのインタフェースを、NAT(PAT)において外部側(=WAN 側)として定義する。
Router(config-if)#encapsulation pppレイヤ2フレームをカプセル化する方式として、pppプロトコルを利用する。
Router(config-if)#keepalive 600 
▲Router(config-if)#dialer string setuzoku1111 
▲Router(config-if)#dialer string TOW00000088335010 modem-script modemcap1111 system-script setuzoku1111ダイヤル番号、モデムスクリプト、ダイヤルする際に使うスクリプトを設定。
*ダイヤル番号について
 電話回線がパルス回線の場合:POW0088335010
 電話回線がプッシュ(=トーン)回線の場合:TOW0088335010
 電話回線がIP電話回線の場合:TOW00000088335010
Router(config-if)#dialer in-bandこのインタフェースで、DDR(=DialOnDemandRouting。)を有効にする。
=このインタフェースに、ダイヤラーリストNo.001で設定した内容のパケットが入ってきたら、ダイヤルアップするようにする。
Router(config-if)#dialer-group 1ダイヤラーリストNo.001を、このインターフェイスに適用する。
*このコマンドは、上記の「dialer in-band」コマンド実施後に入力する必要あり。
Router(config-if)#dialer idle-timeout 0このインタフェースが何秒間、無通信状態になったら、
このインタフェースを切断するかの設定。単位:秒。
「0」とした場合、無通信となっても切断しない。(=常時接続等の場合に「0」とする。)
Router(config-if)#no peer default ip address 
Router(config-if)#no peer neighbor-routePeerの /32ビットルートをルーティングテーブルにインストールしないようにする。
ホストルートが注入され、リンクフラップしないようにするために設定する。
*リンクフラップ:インターフェイスが継続的にアップ状態とダウン状態を繰り返すこと。リンク フラップの一般的な原因は、ケーブルの不良、デュプレックスのミスマッチなどのレイヤ 1 の問題です。
Router(config-if)#no fair-queueWFQを使用しない。
Router(config-if)#no ppp lcp fast-start 
Router(config-if)#ppp authentication chap pap callin*callin(=ISP による片方向認証を行う)
▲Router(config-if)#ppp chap hostname solo 
▲Router(config-if)#ppp chap password solo 
Router(config-if)#ppp pap sent-username solo password 0 solo 
Router(config-if)#ip tcp header-compression passive対向がTCPヘッダ圧縮してきたときのみ、TCPヘッダを圧縮するように設定。
Router(config-if)#exit 
 
Router(config)#line 1~*「1」の部分は、TTYの回線番号。事前に、show lineで調べておく。
Router(config-line)#no exec 
Router(config-line)#exec-timeout 0 0 
Router(config-line)#stopbits 1 
Router(config-line)#speed 115200 
Router(config-line)#flowcontrol hardware 
Router(config-line)#modem InOutモデムを、着呼と発呼の両方で使用できるようにする
Router(config-line)#modem autoconfigure type modemcap1111 
Router(config-line)#flush-at-activation 
Router(config-line)#script dialer setuzoku1111 
Router(config-line)#transport input all 
Router(config-line)#autoselect ppp着信した接続がPPPだった場合、PPPを起動する(pppをslipにかえればSLIPが起動)
Router(config-line)#login 
Router(config-line)#autoselect during-loginキャラクタ接続を待ち受ける。キャラクタ接続されると、自動的に改行コードが入力され、 ログイン画面が立ち上がる。
Router(config-line)#exit 
 
Router(config)#exit 
 
Router#copy running-config startup-config 
Router#reload 
上記設定にて、回線を切断したい場合
Router#start-chat setudan1111 1


確認コマンド
・ダイヤルアップ時の認証状況をリアルタイムで確認
Router#debug ppp authentication
00:45:17: Se0 PPP: Treating connection as a callout
00:45:18: Se0 PAP: O AUTH-REQ id 2 len 14 from "solo"
00:45:18: Se0 PAP: I AUTH-ACK id 2 len 5
"赤字の箇所が、
 NAK だと、認証に失敗している。
 ACK だと、認証に成功している。"

・ダイヤルアップ接続後、接続が確立しているか確認
Router#show line 1


参考
http://www.cisco.com/japanese/warp/public/3/jp/ser...
http://www.grandarbre.net/old/cisco/basic.html
http://www.cisco.com/JP/support/public/ht/tac/100/...

<参考>
http://syn.cocolog-nifty.com/access/2004/12/post.h...
http://www.nifty.com/netphone/faq/04.htm#q04-04
http://www.nifty.com/netphone/faq/04.htm#q04-05

<メモ>
・電話番号に、#や*が入っていると、なぜか発呼に失敗する。
 PCとモデムを直接接続し、モデム上で、ATコマンド入力では正常に動作するので、
 Ciscoルータのchat-script等の影響の可能性が高い?
 #や*を含んだ番号は、内線電話等で利用されている。


DDR
参考>
http://www6.ocn.ne.jp/~caribou/i-mode/cisco-ddr-5....
http://horizondatacom.com/services/articles/articl...



Consoleポートにモデムを接続
http://www.cisco.com/japanese/warp/public/3/jp/ser...


エラーメッセージの意味
メッセージ意味解決策
%Remove Legacy DDR Configuration first このメッセージが出たインタフェースにて、既登録の、dialer map 〜を、no dialer map 〜を使って削除する。
%Configure a "dialer in-band", or "dialer pool" first.| |このメッセージが出たインタフェースにて、先にdialer inband か dialer pool の設定をする。|

コメントをかく


「http://」を含む投稿は禁止されています。

利用規約をご確認のうえご記入下さい

▼当HP内検索▼

▼メインメニュー▼



管理者用リンク
書籍(技術書)
・利用ソフト一覧
・Ethereal/Wireshark

転送速度




・powershell

・VBA










・Microsoft SQLserver








●CentOS6.9


▼動画サーバ関係

MP3について
DVDからのMP3変換について?
DVDからの動画変換について



▼自転車関係
・Panasonic CRAZY BOY

▼自動車関係
・SUZUKI エブリワゴンDA62W


▼Linux/Unix関係
・Linux基礎(パッケージ)
・Linux基礎(システム構成)
・Linux(Debian)基本コマンド
・Linuxコマンド(テキスト処理)
・Linuxコマンド(未整理)
・Linuxコマンド(ネットワーク系)
・FedoraCore OS メモ
・Debian Linux OS メモ
・Vine Linux OS メモ
・xPUD メモ

・CentOS6.4(minimal)


・solaris9 メモ
・solaris10 メモ

▼CCNA関係


▼ノートPC関連

液晶パネル

Fujitsu FMV-820MT
・Compaq Evo Notebook N110
・Panasonic Let's note CF-S51R
・Toshiba Dynabook Satellite 1800


▼デスクトップPC関連
・AOpen AX3S Pro-U
・ASUS CUSL2
・ASUS CUSL2-M


▼携帯電話
・NTT DoCoMo FOMA M1000
・FOMA P704iμ


▼モデム関連
▼ADSLモデム
・NTT ADSLモデム-NV
・NEC PA-WD605CV
・NEC PA-WD701CV
▼アナログモデム
・GVC F-1156IV/R9

▼ルータ関連
▼ルータ
・OMRON MR504DV
・FON La Fonera FON2100E
・Cisco Cisco2620
・Cisco4500M
・Cisco1601
  Cisco1603-R
  Cisco1605

・Cisco 共通メモ

・BUFFALO BLR3-TX4L
・I・O DATA NP-BBR
・NEC PA-WB7000/B (AtermWB7000H)
・マイクロ総研 NetGenesis OPT
・Persol PBR001

・YAMAHA NetVolante RTA54i
・FUJITSU NetVehicle-I

▼イーサネットコンバータ関連
・LINKSYS WET11

▼TA関連
・NEC AtermIT60D1L(S)

▼ハブ関連
・Cisco Catalyst 2924-XL-EN
・AlliedTelesis CentreCOM8216XL2
・BUFFALO LSW10/100-8
・corega FSW-5PM
・corega HUB-5PM
・CONTEC RT-1216S

▼NIC関連
・BUFFALO WLI-U2-SG54HP
・PLANEX GW-NS54GMX
・NTT-ME MN SS-LAN CARD 11 HQ

▼プリンタサーバ関連
・corega Pserver
・I・O DATA PLANT ET-FPS1E

▼デジカメ関連
・MINOLTA DiMAGE F100

▼携帯電話ケーブル関連
・BUFFALO IGM-UPDC
・OMRON ME64KTID
・OMRON ME96KTI
・SOURCENEXT SUS-USB-02 REV.1
・UP12 USB-PDC Converter
・DAISO D106

▼その他PC周辺機器
●キーボード
・Bluetoothキーボード BK3001BA
●ハンディターミナル
・ENSO BHT-6500
●ダウンスキャンコンバータ
・SC-TVEX
●CD-ROMドライブ
・NEC CD-2800D
・BUFFALO CDN-D24EX
・BUFFALO DVM-RDM16IU2
●MOドライブ
・ELECOM LMO-230-S
・FUJITSU MCF3064SS
・FUJITSU SMB-640WL2
●スピーカー
・Justy JSP-10W
●MP3プレーヤ
・SanDisk sansa e130
・NHJ V@mp VP-415
●インタフェースカード
・玄人志向 USB2.0+1394a-CB
・nbj IDE-3525
・Notebook Power Sharing
●ACアダプタ
・Universal AC Adaptor
●マウス
・Logitec Marble Mouse
・needs progres TN-30RFMOSG
●タブレット
・WACOM FAVO(ET-0405-U)
●その他
・IDEAL ME-320X(ME-320U2F)
・KY-05046S-12-H
・LifeView USB CapView
・ハードウェア(その他)
●シリアルレベルコンバータ
・シリアルレベルコンバータ


▼Windows系メモ
・DOS起動ディスク
・Microsoft OS メモ
・Microsoft 系ソフト メモ
・その他 ソフトウェアメモ
・Network Notepad
・Packet Tracerメモ
・パノラマ写真作成ソフト
・トラブル対処履歴


▼プログラミング関連
・言語比較
・VBS
・卒研事前メモ
・卒研メモ
・Windowsプログラミング
・JANコード・ISBNコード相互変換
●C言語
・文字列
・ファイル操作
●アルゴリズム
・再帰アルゴリズム
●JAVA
・Javaプログラミング
●その他
・初心者プログラミング
・ソフトウェア未整理メモ



▼家電関連
●テレビ
・SHARP AQUOS LC-20D10
・FUNAI TV-14CP
・BLUEDOT BTV-900K
・AKART AK-FTV913
・REAL LIFE JAPAN IQ-191LEDTV
AQUOS DZ3シリーズのDLNA機能
Viera V1シリーズのDLNA機能
●プロジェクタ
・crenova XPE470
●ビデオ
・FUNAI TV-14CP
●HDD&DVDレコーダ
・Toshiba RD-XS46
・NEC PK-AX10
●DVDプレーヤー
・GREEN HOUSER GH-PDV9AT
・情熱価格 DVDJ-DQ03
●メディアプレーヤー
・MINI HD MEDIA BOX 1080P
・1080P FULL HD Media Player
・1080P HD Media Player Mini 1080
・HD media player

●チューナー
・COMTEC DTW700
・HUMAX CI-S1

●アンテナ
・ADDZEST ZCP107
・マルハマ AGS-590

●ヘッドマウントディスプレイ
・VIRTUAL i/O i-glasses
●電動歯ブラシ
・ブラウン電動歯ブラシ
●電話機
・SHARP DA-C5-B
●コードレス電動ドリル、ドライバ
・BLACK&DECKER CSD300T
・RELIEF 30946?

▼カーナビ関係
Panasonic CN-GP510VD
Panasonic CN-G1100VD
▼カーステレオ関係
Kenwood U585SD

▼おもちゃ関連
●ラジコン
・ラジコンのプロポ改造


▼カー用品関連
●インダッシュTV
・ADDZEST TVS6250


▼DIY関連
・懸垂スタンド
・蓄光塗料


▼電子工作関係
・コネクタピンアサイン
・LANケーブルをAVケーブル化
・LANケーブルをRGBケーブル化
・地上デジタル放送アンテナ
・電子工作 メモ
・乾電池を充電


▼デザイン関連
●腕時計
・腕時計


▼その他

・HP製作関連メモ
・アイデアメモ

・コラム・メモ
・趣味・興味


・ToDo
・ネットインフラ?


▼資格・履歴書・マナー
・資格取得メモ
・工事担任者対策メモ
・履歴書・職務経歴書
・答辞


▼修学旅行 フランス(パリ)


▼掲示板
●掲示板
 意見・苦情・質問用に仮設置。

▼フリーエリア▼

▼おしらせ▼

管理人/副管理人のみ編集できます