<概念>
インターネット(WAN)にアクセスする際、
プライベートアドレスを、グローバルアドレスに変換する技術。
利点:
・WAN側から、LAN側のIPアドレスを知られることもなくなるため、セキュリティが向上する。
・全てのPCにグローバルアドレスを割り当てる必要がなくなるため、
 IPアドレスの枯渇防止に繋がる。

<CISCO独自の、アドレスの呼び方>
             内部ローカル     外部ローカル     内部グローバル     外部グローバル
<クライアント(=自分)>―――――――――――――<ルータ>―――――――――――――<サーバ(=目的地)>
Static NAT
<使用例>
ISPから1つのグローバルIPアドレスをもらい、
1台のPCしか使わないので、1対1の関係で固定的に相互変換して使うとき。

LAN――――――――――――――――<R1111>―――――――――WAN
PC1:192.168.1.2/24      192.168.1.1/24       10.0.0.1/24

R1111(config)#interface ethernet 0
R1111(config-if)#ip address 192.168.1.1 255.255.255.0
R1111(config-if)#ip nat inside
R1111(config-if)#no shutdown

R1111(config)#interface serial 0
R1111(config-if)#ip address 10.0.0.1 255.0.0.0
R1111(config-if)#ip nat outside
R1111(config-if)#no shutdown

R1111>enable
R1111#configure terminal
R1111(config)#ip nat inside source static 192.168.1.2 10.0.0.1


Dynamic NAT
<使用例>
ISPからグローバルIPアドレスを3つもらい、
社内のPC4つで、排他的に自動割り当て利用しながら使うとき。

LAN――――――――――――――――<R1111>―――――――――WAN
PC1:192.168.1.2/24      192.168.1.1/24       10.0.0.1/24
PC2:192.168.1.3/24                      10.0.0.2/24
PC3:192.168.1.4/24                      10.0.0.3/24
PC4:192.168.1.5/24

R1111(config)#interface ethernet 0
R1111(config-if)#ip address 192.168.1.1 255.255.255.0
R1111(config-if)#ip nat inside
R1111(config-if)#no shutdown

R1111(config)#interface serial 0
R1111(config-if)#ip nat outside
R1111(config-if)#no shutdown

R1111>enable
R1111#configure terminal
R1111(config)#ip nat pool AAAA 10.0.0.1 10.0.0.3 netmask 255.0.0.0
R1111(config)#access-list 99 permit 192.168.1.0 0.0.0.255
R1111(config)#ip nat inside source list 99 pool AAAA


PAT
一般的には、IPマスカレード、NAT+、アドバンスドNAT などとも言われる手法。
<使用例>
ISPから1つのグローバルIPアドレスをもらい、
社内のPC4つで、同時利用しながら使うとき。
*それぞれのPCは、1つのグローバルIPアドレスを
 ポート番号レベルで利用するため、同時にネットアクセスできる。

LAN――――――――――――――――<R1111>―――――――――WAN
PC1:192.168.1.2/24      192.168.1.1/24       10.0.0.1/24
PC2:192.168.1.3/24
PC3:192.168.1.4/24
PC4:192.168.1.5/24

R1111(config)#interface ethernet 0
R1111(config-if)#ip address 192.168.1.1 255.255.255.0
R1111(config-if)#ip nat inside
R1111(config-if)#no shutdown

R1111(config)#interface serial 0
R1111(config-if)#ip address 10.0.0.1 255.0.0.0
R1111(config-if)#ip nat outside
R1111(config-if)#no shutdown

R1111>enable
R1111#configure terminal
R1111(config)#access-list 99 permit 192.168.1.0 0.0.0.255
R1111(config)#ip nat inside source list 99 interface serial 0 overload



●確認コマンド
変換テーブルの表示

Router#show ip nat transration



参考:
http://72.14.235.104/search?q=cache:EdoWCFAxE1wJ:b...

http://www.netagency.biz/ccie/073.html
http://www.ciscoman.net/ccna/html/nat_06.html

コメントをかく


「http://」を含む投稿は禁止されています。

利用規約をご確認のうえご記入下さい

▼当HP内検索▼

▼メインメニュー▼



管理者用リンク
書籍(技術書)
・利用ソフト一覧
・Ethereal/Wireshark

転送速度




・powershell

・VBA










・Microsoft SQLserver








●CentOS6.9


▼動画サーバ関係

MP3について
DVDからのMP3変換について?
DVDからの動画変換について



▼自転車関係
・Panasonic CRAZY BOY

▼自動車関係
・SUZUKI エブリワゴンDA62W


▼Linux/Unix関係
・Linux基礎(パッケージ)
・Linux基礎(システム構成)
・Linux(Debian)基本コマンド
・Linuxコマンド(テキスト処理)
・Linuxコマンド(未整理)
・Linuxコマンド(ネットワーク系)
・FedoraCore OS メモ
・Debian Linux OS メモ
・Vine Linux OS メモ
・xPUD メモ

・CentOS6.4(minimal)


・solaris9 メモ
・solaris10 メモ

▼CCNA関係


▼ノートPC関連

液晶パネル

Fujitsu FMV-820MT
・Compaq Evo Notebook N110
・Panasonic Let's note CF-S51R
・Toshiba Dynabook Satellite 1800


▼デスクトップPC関連
・AOpen AX3S Pro-U
・ASUS CUSL2
・ASUS CUSL2-M


▼携帯電話
・NTT DoCoMo FOMA M1000
・FOMA P704iμ


▼モデム関連
▼ADSLモデム
・NTT ADSLモデム-NV
・NEC PA-WD605CV
・NEC PA-WD701CV
▼アナログモデム
・GVC F-1156IV/R9

▼ルータ関連
▼ルータ
・OMRON MR504DV
・FON La Fonera FON2100E
・Cisco Cisco2620
・Cisco4500M
・Cisco1601
  Cisco1603-R
  Cisco1605

・Cisco 共通メモ

・BUFFALO BLR3-TX4L
・I・O DATA NP-BBR
・NEC PA-WB7000/B (AtermWB7000H)
・マイクロ総研 NetGenesis OPT
・Persol PBR001

・YAMAHA NetVolante RTA54i
・FUJITSU NetVehicle-I

▼イーサネットコンバータ関連
・LINKSYS WET11

▼TA関連
・NEC AtermIT60D1L(S)

▼ハブ関連
・Cisco Catalyst 2924-XL-EN
・AlliedTelesis CentreCOM8216XL2
・BUFFALO LSW10/100-8
・corega FSW-5PM
・corega HUB-5PM
・CONTEC RT-1216S

▼NIC関連
・BUFFALO WLI-U2-SG54HP
・PLANEX GW-NS54GMX
・NTT-ME MN SS-LAN CARD 11 HQ

▼プリンタサーバ関連
・corega Pserver
・I・O DATA PLANT ET-FPS1E

▼デジカメ関連
・MINOLTA DiMAGE F100

▼携帯電話ケーブル関連
・BUFFALO IGM-UPDC
・OMRON ME64KTID
・OMRON ME96KTI
・SOURCENEXT SUS-USB-02 REV.1
・UP12 USB-PDC Converter
・DAISO D106

▼その他PC周辺機器
●キーボード
・Bluetoothキーボード BK3001BA
●ハンディターミナル
・ENSO BHT-6500
●ダウンスキャンコンバータ
・SC-TVEX
●CD-ROMドライブ
・NEC CD-2800D
・BUFFALO CDN-D24EX
・BUFFALO DVM-RDM16IU2
●MOドライブ
・ELECOM LMO-230-S
・FUJITSU MCF3064SS
・FUJITSU SMB-640WL2
●スピーカー
・Justy JSP-10W
●MP3プレーヤ
・SanDisk sansa e130
・NHJ V@mp VP-415
●インタフェースカード
・玄人志向 USB2.0+1394a-CB
・nbj IDE-3525
・Notebook Power Sharing
●ACアダプタ
・Universal AC Adaptor
●マウス
・Logitec Marble Mouse
・needs progres TN-30RFMOSG
●タブレット
・WACOM FAVO(ET-0405-U)
●その他
・IDEAL ME-320X(ME-320U2F)
・KY-05046S-12-H
・LifeView USB CapView
・ハードウェア(その他)
●シリアルレベルコンバータ
・シリアルレベルコンバータ


▼Windows系メモ
・DOS起動ディスク
・Microsoft OS メモ
・Microsoft 系ソフト メモ
・その他 ソフトウェアメモ
・Network Notepad
・Packet Tracerメモ
・パノラマ写真作成ソフト
・トラブル対処履歴


▼プログラミング関連
・言語比較
・VBS
・卒研事前メモ
・卒研メモ
・Windowsプログラミング
・JANコード・ISBNコード相互変換
●C言語
・文字列
・ファイル操作
●アルゴリズム
・再帰アルゴリズム
●JAVA
・Javaプログラミング
●その他
・初心者プログラミング
・ソフトウェア未整理メモ



▼家電関連
●テレビ
・SHARP AQUOS LC-20D10
・FUNAI TV-14CP
・BLUEDOT BTV-900K
・AKART AK-FTV913
・REAL LIFE JAPAN IQ-191LEDTV
AQUOS DZ3シリーズのDLNA機能
Viera V1シリーズのDLNA機能
●プロジェクタ
・crenova XPE470
●ビデオ
・FUNAI TV-14CP
●HDD&DVDレコーダ
・Toshiba RD-XS46
・NEC PK-AX10
●DVDプレーヤー
・GREEN HOUSER GH-PDV9AT
・情熱価格 DVDJ-DQ03
●メディアプレーヤー
・MINI HD MEDIA BOX 1080P
・1080P FULL HD Media Player
・1080P HD Media Player Mini 1080
・HD media player

●チューナー
・COMTEC DTW700
・HUMAX CI-S1

●アンテナ
・ADDZEST ZCP107
・マルハマ AGS-590

●ヘッドマウントディスプレイ
・VIRTUAL i/O i-glasses
●電動歯ブラシ
・ブラウン電動歯ブラシ
●電話機
・SHARP DA-C5-B
●コードレス電動ドリル、ドライバ
・BLACK&DECKER CSD300T
・RELIEF 30946?

▼カーナビ関係
Panasonic CN-GP510VD
Panasonic CN-G1100VD
▼カーステレオ関係
Kenwood U585SD

▼おもちゃ関連
●ラジコン
・ラジコンのプロポ改造


▼カー用品関連
●インダッシュTV
・ADDZEST TVS6250


▼DIY関連
・懸垂スタンド
・蓄光塗料


▼電子工作関係
・コネクタピンアサイン
・LANケーブルをAVケーブル化
・LANケーブルをRGBケーブル化
・地上デジタル放送アンテナ
・電子工作 メモ
・乾電池を充電


▼デザイン関連
●腕時計
・腕時計


▼その他

・HP製作関連メモ
・アイデアメモ

・コラム・メモ
・趣味・興味


・ToDo
・ネットインフラ?


▼資格・履歴書・マナー
・資格取得メモ
・工事担任者対策メモ
・履歴書・職務経歴書
・答辞


▼修学旅行 フランス(パリ)


▼掲示板
●掲示板
 意見・苦情・質問用に仮設置。

▼フリーエリア▼

▼おしらせ▼

管理人/副管理人のみ編集できます