hack のためのネタ帳, etc,,,

状況

Cygwin を dist-upgrade したせいか、以下のようなエラーが出る。
> library(ggplot2)
 エラー: package or namespace load failed for ‘ggplot2’:
 package ‘scales’ was installed by an R version with different internals; it needs to be reinstalled for use with this R version
一括で reinstall する方法が分からなかったので、needs to be reinstalled って言われるたびに片っ端から install.packages() を繰り返す羽目に orz

reinstall した pakcage は以下
install.packages("scales")
install.packages("Rcpp")
install.packages("scales")
install.packages("colorspace")
install.packages("scales")
install.package("lazyeval")
install.packages("lazyeval")
install.packages("plyr")
install.packages("rlang")
install.packages("tibble")

やれやれだぜ

コメントをかく


「http://」を含む投稿は禁止されています。

利用規約をご確認のうえご記入下さい

Wiki内検索

フリーエリア

編集にはIDが必要です