Linux¤Î¥Õ¥¡¥¤¥ë¥·¥¹¥Æ¥à¤ò¾Ü²ò¤·¤Þ¤¹

FrontPage > kernel > 2.6.25-rc1 > 2.6.25-rc1_shortlog10

Glauber de Oliveira Costa (124):
lguest: fix drivers/lguest Makefile entry
lguest: remove pv_info dependency
lguest: introduce vcpu struct
lguest: adapt launcher to per-cpuness
lguest: initialize vcpu
lguest: per-cpu run guest
lguest: make write() operation smp aware
lguest: make hypercalls use the vcpu struct
lguest: per-vcpu lguest timers
lguest: per-vcpu interrupt processing.
lguest: map_switcher_in_guest() per-vcpu
lguest: make emulate_insn receive a vcpu struct.
lguest: make registers per-vcpu
lguest: replace lguest_arch with lg_cpu_arch.
lguest: per-vcpu lguest task management
lguest: makes special fields be per-vcpu
lguest: make pending notifications per-vcpu
lguest: per-vcpu lguest pgdir management
lguest: change spte_addr header
lguest: change last_guest to last_cpu
lguest: move last_pages to lg_cpu
lguest: move changed bitmap to lg_cpu
lguest: change gpte_addr header
lguest: get rid of lg variable assignments
lguest: Use explicit includes rateher than indirect
lguest: use __PAGE_KERNEL instead of _PAGE_KERNEL
x86: irqflags consolidation
x86: consolidate spinlock.h
x86: wipe out traditional opt from x86_64 Makefile
x86: unify msr smp funcs
x86: allow sched clock to be overridden by paravirt
x86: split get_cycles_sync
x86: unify cpuid functions
x86: introduce native_read_tscp
x86: change rdpmc interface
x86: change write msr functions interface
x86: make fixups wordsize agnostic
x86: integrate 32-bit and 64-bit code in msr.h
x86: remove volatile keyword from clflush.
x86: put together equal pieces of system.h
x86: unify load_segment macro
x86: unify paravirt parts of system.h
x86: remove unused macro
x86: unify smp parts of system.h
x86: move switch_to macro to system.h
x86: unify system.h
x86: put get_kernel_rpl in a common location
x86: unify common parts of segment.h
x86: remove arch specific segment headers
x86: export math_state_restore
x86: export cpu_gdt_descr
x86: turn priviled operation into a macro in head_64.S
x86: prepare time related functions for paravirt
x86: tweak io_64.h for paravirt.
x86: prepare 64-bit architecture initialization for paravirt
x86: unify desc_struct
x86: unify struct desc_ptr
x86: change gdt acessor macro name
x86: removed unused variable
x86: introduce gate_desc type.
x86: change write_idt_entry signature
x86: introduce ldt_desc type.
x86: modify write_ldt function
x86: introduce fill_ldt
x86: provide tss_desc
x86: change write_gdt_entry signature.
x86: change write_ldt_entry signature
x86: move constants to desc_defs.h
x86: unify non-paravirt parts of desc.h
x86: use the same data type for tls_array.
x86: modify get_desc_base
x86: unify paravirt pieces of descriptor handling
x86: move _set_gate and its users to a common location
x86: unify set_tss_desc
x86: avoid ifdefs in desc.h, getting rid of pack_ldt and pack_tss
x86: move tsc definitions to were they belong
x86: get rid of _MASK flags
x86: move desc_empty to where they belong
x86: move load_cr3 to a common place.
x86: unify paravirt pieces of processor.h
x86: move the definition of set_iopl_mask to common header
x86: unify common parts of processor.h
x86: unify current_text_addr
x86: unify tss_struct
x86: provide 64-bit with a load_sp0 function.
x86: unify thread struct.
x86: unify TASK_ALIGN definitions
x86: change bitwise operations to get a void parameter.
x86: unify x86_cpuinfo struct.
x86: remove legacy stuff from processor_64.h
x86: unify mm_segment_t definition
x86: move definitions to processor.h
x86: unify prefetch operations
x86: unify asm nops
x86: move i387 definitions to processor.h
x86: remove __init modifier from header declaration
x86: finish processor.h integration
x86: change paravirt_32.c name
x86: adjust PVOP_CALL/VCALL macros for 64-bit
x86: cleanup write_tsc
x86: provide paravirtualized hook for rdtscp
x86: change assembly definition of paravirt_patch_site
x86: adjust assembly macros on 64-bit as well.
x86: change irq functions to accomodate 64-bit
x86: add macro for privileged 64-bit operation
x86: adds paravirt hook for swapgs
x86: replace privileged instructions with paravirt macros
x86: cleanup CLI_STRING, STI_STRING and friends
x86: add CLBR_ defines for 64-bit
x86: move patching code to arch-specific file.
x86: patching functions on 64-bit
replace x86_read/write_per_cpu with a common function.
x86: add stringify header
x86: provide a native_init_IRQ function on 64-bit
x86: put generic mm_hooks include into PARAVIRT
x86: puts read and write cr8 into pv_cpu_ops
x86: provide read and write cr8 paravirt hooks
x86: fill pv_cpu_ops structure with cr8 fields
x86: add asm_offset PARAVIRT constants
x86: provide __parainstructions section
x86: change function orders in paravirt.h
x86: export check_tsc_unstable
x86: export __supported_pte_mask
KVM: Put kvm_para.h include outside KERNEL

Glenn Streiff (1):
RDMA/nes: Add a driver for NetEffect RNICs

Gordon Farquharson (1):
[ARM] 4770/1: GLAN Tank: correct physmap_flash_data width field

Graeme Gregory (2):
[ALSA] soc - Reinitialise DMA on every resume
[ALSA] soc - Support suspend and resume of the I2S interface on s3c24xx

Grant Grundler (2):
USB: storage: Add unusual_dev for HP r707
PCI: Remove pci_enable_device_bars() from documentation

Grant Likely (21):
[POWERPC] Add machine initcall macros
[POWERPC] 4xx: typo in calling machine_device_initcall() for Sequoia board
[POWERPC] pasemi: Use machine_*_initcall() hooks in platform code
[POWERPC] Add of_find_matching_node() helper function
[POWERPC] powermac: Use machine_*_initcall() hooks in platform code
[POWERPC] cell: Use machine_*_initcall() hooks in platform code
[POWERPC] mpc5200: eliminate mpc52xx_*_map_*() functions.
[POWERPC] mpc5200: merge defconfigs for all mpc5200 boards
[POWERPC] 8xx: Use machine_*_initcall() hooks in platform code
[POWERPC] mpc52xx: clean up Kconfig
[POWERPC] mpc5200: normalize compatible property bindings
[POWERPC] mpc5200: make dts files conform to generic names recommended practice
[POWERPC] Efika: prune fixups and make them more carefull
[POWERPC] Add common clock setting routine mpc52xx_psc_set_clkdiv()
[POWERPC] mpc52xx_psc_spi device driver must not touch port_config and cdm
[POWERPC] 82xx and embedded6xx: Use machine_*_initcall() hooks in platform code
gianfar driver: eliminate compiler warnings and unnecessary macros
[POWERPC] Fix incorrectly tagged __devinitdata structures
[POWERPC] Eliminate broken OF console initialization.
[POWERPC] bootwrapper: Build multiple cuImages
[POWERPC] mpc52xx: fix compile error introduce when rebasing patch

Greg Kroah-Hartman (166):
kobject: remove incorrect comment in kobject_rename
ecryptfs: clean up attribute mess
kobject: convert ibmasm to use kref, not kobject
kobject: convert hvc_console to use kref, not kobject
kobject: convert hvcs to use kref, not kobject
kobject: convert icom to use kref, not kobject
kobject: fix up kobject_set_name to use kvasprintf
kobject: make kobject_cleanup be static
kobject: add kobject_init_ng function
kobject: add kobject_add_ng function
kobject: add kobject_init_and_add function
kobject: remove struct kobj_type from struct kset
kobject: remove kobj_set_kset_s as no one is using it anymore
kset: add kset_create_and_add function
kobject: add kobject_create_and_add function
kobject: get rid of kobject_add_dir
kobject: get rid of kobject_kset_add_dir
kobject: convert fuse to use kobject_create
kobject: convert securityfs to use kobject_create
kobject: convert debugfs to use kobject_create
kobject: convert configfs to use kobject_create
kset: convert ecryptfs to use kset_create
kobject: convert main fs kobject to use kobject_create
kset: convert gfs2 to use kset_create
kset: convert gfs2 dlm to use kset_create
kset: convert dlm to use kset_create
kset: convert pci hotplug to use kset_create_and_add
kset: remove decl_subsys_name
kset: convert kernel_subsys to use kset_create
kset: convert drivers/base/bus.c to use kset_create
kset: convert drivers/base/class.c to use kset_create
kset: convert drivers/base/firmware.c to use kset_create
kset: convert /sys/devices to use kset_create
kobject: convert /sys/hypervisor to use kobject_create
kobject: convert s390 hypervisor to use kobject_create
kset: convert /sys/devices/system to use kset_create
kset: convert slub to use kset_create
kset: move /sys/slab to /sys/kernel/slab
kset: convert /sys/module to use kset_create
kset: convert /sys/power to use kset_create
kset: convert struct bus_device->devices to use kset_create
kset: convert struct bus_device->drivers to use kset_create
ecryptfs: remove version_str file from sysfs
efivars: make new_var and del_var binary sysfs files
kobject: convert efivars to kobj_attr interface
firmware: export firmware_kset so that people can use that instead of the braindead firmware_register interface
kset: convert efivars to use kset_create for the efi subsystem.
kset: convert efivars to use kset_create for the vars sub-subsystem.
kobject: convert arm/mach-omap1/pm.c to kobj_attr interface
kobject: convert pseries/power.c to kobj_attr interface
kobject: convert s390 ipl.c to kobj_attr interface
kset: convert s390 ipl.c to use kset_create
kobject: convert parisc/pdc_stable to kobj_attr interface
kset: convert parisc/pdc_stable.c to use kset_create
kset: convert edd to use kset_create
kobject: convert /sys/firmware/acpi/ to use kobject_create
firmware: remove firmware_(un)register()
firmware: change firmware_kset to firmware_kobj
kset: convert ocfs2 to use kset_create
kset: convert block_subsys to use kset_create
kset: remove decl_subsys macro
kobject: convert kernel_kset to be a kobject
kobject: remove subsystem_(un)register functions
kobject: clean up rpadlpar horrid sysfs abuse
kobject: convert ecryptfs to use kobject_create
kobject: convert efivars to use kobject_create
kobject: convert parisc/pdc_stable to use kobject_create
driver core: clean up shutdown.c
driver core: clean up device_shutdown
driver core: make /sys/power a kobject
kobject: grab the kset reference in kobject_add, not kobject_init
kobject: clean up debugging messages
UIO: fix kobject usage
Kobject: change net/bridge to use kobject_create_and_add
Kobject: change GFS2 to use kobject_init_and_add
Kobject: change drivers/infiniband to use kobject_init_and_add
Kobject: change drivers/firmware/edd.c to use kobject_init_and_add
Kobject: change drivers/firmware/efivars.c to use kobject_init_and_add
Kobject: change drivers/cpufreq/cpufreq.c to use kobject_init_and_add
Kobject: change drivers/edac to use kobject_init_and_add
Kobject: change drivers/cpuidle/sysfs.c to use kobject_init_and_add
Kobject: change drivers/pci/hotplug/pci_hotplug_core.c to use kobject_init_and_add
Kobject: change drivers/base/sys.c to use kobject_init_and_add
Kobject: change arch/x86/kernel/cpu/intel_cacheinfo.c to use kobject_init_and_add
Kobject: change drivers/acpi/system.c to use kobject_create_and_add
Kobject: change drivers/block/pktcdvd.c to use kobject_init_and_add
Kobject: change arch/sh/kernel/cpu/sh4/sq.c to use kobject_init_and_add
Kobject: change drivers/net/ibmveth.c to use kobject_init_and_add
Kobject: change drivers/parisc/pdc_stable.c to use kobject_init_and_add
Kobject: change arch/ia64/kernel/topology.c to use kobject_init_and_add
Kobject: change drivers/md/md.c to use kobject_init_and_add
Kobject: change arch/x86/kernel/cpu/mcheck/mce_amd_64.c to use kobject_create_and_add
Kobject: change arch/x86/kernel/cpu/mcheck/mce_amd_64.c to use kobject_init_and_add
Kobject: the cris iop_fw_load.c code is broken
Kobject: convert drivers/base/class.c to use kobject_init/add_ng()
Kobject: convert drivers/base/core.c to use kobject_init/add_ng()
Kobject: convert drivers/net/iseries_veth.c to use kobject_init/add_ng()
Kobject: convert fs/char_dev.c to use kobject_init/add_ng()
Kobject: convert kernel/params.c to use kobject_init/add_ng()
Kobject: convert kernel/user.c to use kobject_init/add_ng()
Kobject: convert mm/slub.c to use kobject_init/add_ng()
Kobject: convert net/bridge/br_if.c to use kobject_init/add_ng()
driver core: remove owner field from struct bus_type
driver core: add way to get to bus kset
driver core: add way to get to bus device klist
driver core: remove fields from struct bus_type
USB: use proper call to driver_create_file
PCMCIA: use proper call to driver_create_file
PCI: use proper call to driver_create_file
PCI: remove foolish code from pci-driver.c
Infiniband: make ipath driver use default driver groups.
Driver: add driver_add_kobj for looney iseries_veth driver
Driver core: move the driver specific module code into the driver core
Driver core: move the static kobject out of struct driver
Driver core: clean up debugging messages
Kobject: change drivers/base/bus to use kobject_init_and_add
Kobject: convert block/elevator.c to use kobject_init/add_ng()
Kobject: convert block/ll_rw_blk.c to use kobject_init/add_ng()
Kobject: convert drivers/md/md.c to use kobject_init/add_ng()
Kobject: convert kernel/module.c to use kobject_init/add_ng()
Kobject: remove kobject_add() as no one uses it anymore
Kobject: rename kobject_add_ng() to kobject_add()
Kobject: remove kobject_init() as no one uses it anymore
Kobject: rename kobject_init_ng() to kobject_init()
Kobject: remove kobject_register()
Kset: remove kset_add function
Modules: remove unneeded release function
Kobject: convert arch/* from kobject_unregister() to kobject_put()
Kobject: convert drivers/* from kobject_unregister() to kobject_put()
Kobject: convert fs/* from kobject_unregister() to kobject_put()
Kobject: convert remaining kobject_unregister() to kobject_put()
Kobject: remove kobject_unregister() as no one uses it anymore
kobject: remove old, outdated documentation.
kobject: update the kobject/kset documentation
kobject: add sample code for how to use kobjects in a simple manner.
kobject: add sample code for how to use ksets/ktypes/kobjects
Driver core: fix coding style issues in device.h
Kobject: fix coding style issues in kobject.h
Kobject: fix coding style issues in kobject c files
Driver core: coding style fixes
Driver core: Fix up build when CONFIG_BLOCK=N
x86: fix runtime error in arch/x86/kernel/cpu/mcheck/mce_amd_64.c
Module: check to see if we have a built in module with the same name
Driver core: add bus_find_device_by_name function
Module: check to see if we have a built in module with the same name
kobj: fix threshold_init_device/kobject_uevent_env oops
USB: handle idVendor of 0x0000
USB: always announce a device has been added to the system
USB: ftdi_sio: remove very old changelog entries from the file.
USB: use a real vendor and product id for root hubs
USB: mark USB drivers as being GPL only
USB: fix codingstyle issues in include/linux/usb.h
USB: fix codingstyle issues in include/linux/usb/
USB: fix codingstyle issues in drivers/usb/core/*.h
USB: fix codingstyle issues in drivers/usb/core/devices.c
USB: fix codingstyle issues in drivers/usb/core/devio.c
USB: fix codingstyle issues in drivers/usb/core/hcd-pci.c
USB: fix codingstyle issues in drivers/usb/core/message.c
USB: fix codingstyle issues in drivers/usb/core/*.c
PCI: fix codingstyle issues in drivers/pci/pci.h
PCI: fix codingstyle issues in include/linux/pci.h
PCI: make pci_bus a struct device
Revert "PCI: PCIE ASPM support"
pci: pci_enable_device_bars() fix for lpfc driver
Block: Fix whole_disk attribute bug
sysfs: remove BUG_ON() from sysfs_remove_group()

Greg Ungerer (33):
m68knommu: build support for new ColdFire serial driver
m68knommu: configure support for new ColdFire serial driver
m68knommu: platform setup for 5206 ColdFire parts
m68knommu: platform setup for 5206e ColdFire parts
m68knommu: platform setup for 523x ColdFire parts
m68knommu: platform setup for 520x ColdFire parts
m68knommu: platform setup for 5272 ColdFire parts
m68knommu: platform setup for 5249 ColdFire parts
m68knommu: platform setup for 528x ColdFire parts
m68knommu: platform setup for 5307 ColdFire parts
m68knommu: platform setup for 527x ColdFire parts
m68knommu: platform setup for 532x ColdFire parts
m68knommu: platform setup for 5407 ColdFire parts
m68knommu: move ColdFire entry.S to its own coldfire directory
m68knommu: move ColdFire head.S to its own coldfire directory
m68knommu: move ColdFire pit.c to its own coldfire directory
m68knommu: move ColdFire timers.c to its own coldfire directory
m68knommu: move ColdFire vectors.c to its own coldfire directory
m68knommu: modify Makefiles to support common coldfire directory
m68knommu: create common DMA table for ColdFire CPUs
m68knommu: use IRQF_DISABLE in m68328serial.c
m68knommu: remove dead code from m68knommu timer code
m68knommu: use container_of in mcf.c
m68knommu: fix 528x ColdFire cache settings
m68knommu: remove unused CONFIG_DISKtel symbol
m68knommu: switch 68328 timer to use GENERIC_TIME
m68knommu: switch ColdFire PIT timer to use GENERIC_TIME
m68knommu: switch ColdFire TIMER to use GENERIC_TIME
m68knommu: set config to use GENERIC_TIME
m68knommu: remove local gettimeofday code
m68knommu: remove empty timer offset function for 68360
m68knommu: remove dead timer int pending code
m68knommu: use ARRAY_SIZE in ColdFire serial driver

Gregory Greenman (1):
iwlwifi: Fix uCode error on association

Gregory Haskins (15):
sched: add RT-balance cpu-weight
sched: clean up this_rq use in kernel/sched_rt.c
sched: de-SCHED_OTHER-ize the RT path
sched: break out search for RT tasks
sched: RT balancing: include current CPU
sched: pre-route RT tasks on wakeup
sched: optimize RT affinity
sched: wake-balance fixes
sched: break out early if RT task cannot be migrated
sched: RT-balance, optimize
sched: add sched-domain roots
sched: only balance our RT tasks within our domain
sched: RT-balance, only adjust overload state when changing
sched: remove some old cpuset logic
sched: dynamically update the root-domain span/online maps

Guennadi Liakhovetski (6):
[ARM] 4647/1: at91rm9200: Remove redundant machine-type verification and manipulation
[ARM] 4660/3: at91: allow selecting UART for early kernel messages
gpio: rename pca9539 driver
gpio: rename pca953x symbols
gpio: handle pca953{4,5,6,7,8} too
lib/scatterlist.o needed by a module only - link it in unconditionally

Gui Jianfeng (1):
[IPV6]: Remove useless code from fib6_del_route().

Guillaume Chazarain (3):
sched: fix rq->clock warps on frequency changes
sched: monitor clock underflows in /proc/sched_debug
x86: scale cyc_2_nsec according to CPU frequency
¥¿¥°

¤³¤Î¥Ú¡¼¥¸¤Ø¤Î¥³¥á¥ó¥È

2.6.25-rc1_shortlog10 - �ܲ�ե����륷���ƥ� - Seesaa Wiki�ʥ������� for ���ޡ��ȥե��� モンクレール ニット帽 http://www.pslcbi.com/moncler2014.html

0
Posted by ãƒ¢ãƒ³ã‚¯ãƒ¬ãƒ¼ãƒ« ニット帽 2013ǯ12·î09Æü(·î) 18:16:21 ÊÖ¿®

¥³¥á¥ó¥È¤ò¤«¤¯


¡Öhttp://¡×¤ò´Þ¤àÅê¹Æ¤Ï¶Ø»ß¤µ¤ì¤Æ¤¤¤Þ¤¹¡£

ÍøÍѵ¬Ìó¤ò¤´³Îǧ¤Î¤¦¤¨¤´µ­Æþ²¼¤µ¤¤

´ØÏ¢¥½¥Õ¥È/ʸ½ñ

Firefox3 Meter  Use OpenOffice.org

´ÉÍý¿Í/Éû´ÉÍý¿Í¤Î¤ßÊÔ½¸¤Ç¤­¤Þ¤¹